What technical requirements do I need for HUMANOO?

HUMANOO runs on all Android (from 7.1) or iOS (from 13) operating systems.

The service for users who still have the iOS 12 version will not be abruptly discontinued. However, we recommend updating to a newer iOS version.

If your device does not support any of the new iOS versions, you should know the following:

  • New features will not be made available on iOS 12 devices.
  • You can continue to use HUMANOO version 7.6.0 - but we will stop supporting it.
  • If you delete the HUMANOO app on an iOS 12 device, you cannot re-install it from the Appstore.


Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.